CWA location during onboarding

I’m unable to set the CWA location during a computer’s initial onboarding session.

Once the automate agent is installed, if I re-onboard the computer, I’m given the option to select location. I assume this is NOT the intended behavior, but wanted to make sure before I spend time trying to track down the issue.